Decreased Performance
Incident Report for dexi.io
Resolved
This incident has been resolved.
Posted 12 days ago. Aug 03, 2018 - 12:40 CEST
Investigating
We are currently experiencing decreased performance. We are investigating and hope to have a resolution very soon.
Posted 12 days ago. Aug 03, 2018 - 12:20 CEST
This incident affected: Application and Processing.