Commercial wesbite https://dexi.io is down
Incident Report for dexi.io
Resolved
This incident has been resolved.
Posted Jan 22, 2020 - 05:41 CET
Investigating
We are currently investigating this issue.
Posted Jan 22, 2020 - 05:36 CET