System Issues
Incident Report for dexi.io
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 11, 2018 - 11:57 CEST
Investigating
We are experiencing system issues. We are investigating and will report here as soon as we have any updates.
Posted 2 months ago. Jun 11, 2018 - 11:48 CEST
This incident affected: Application and Processing.