System issues
Incident Report for dexi.io
Resolved
All issues should now be resolved. Please contact us if you experience any problems.

We apologise for the inconvenience.
Posted 3 months ago. May 25, 2018 - 09:39 CEST
Investigating
We are experiencing some issues at the moment. We are investigating and will report back as soon as possible.
Posted 3 months ago. May 25, 2018 - 09:10 CEST
This incident affected: Application and Processing.