File storage problems
Incident Report for dexi.io
Resolved
Problem has been resolved. We apologise for the inconvenience.
Posted 10 months ago. Oct 10, 2017 - 10:01 CEST
Investigating
We are experiencing issues with file storage. We are investigating.
Posted 10 months ago. Oct 10, 2017 - 09:23 CEST