Commercial website 'dexi.io' is currenly unavailable to our customers
Incident Report for dexi.io
Resolved
Incident has no been resolved after some strange settings changes inside hubspot
Posted Feb 06, 2020 - 08:41 CET
Investigating
We are currently experiencing problems with our commercial website and are investigating.
Posted Feb 06, 2020 - 08:12 CET
This incident affected: Application & API.