System slowdown
Incident Report for dexi.io
Resolved
The issue has been resolved.
Posted 9 months ago. Oct 26, 2018 - 14:44 CEST
Investigating
We are experiencing a system slowdown at the moment.

We are working hard to resolve it.
Posted 9 months ago. Oct 26, 2018 - 14:13 CEST
This incident affected: Application and Processing.