File storage problems (#2)
Incident Report for dexi.io
Resolved
Problem has now been resolved.
Posted 3 months ago. Oct 10, 2017 - 11:08 CEST
Investigating
The file storage problem unfortunately was *not* resolved.

We are re-investigating.
Posted 3 months ago. Oct 10, 2017 - 10:07 CEST