We're currently experiencing issues
Incident Report for dexi.io
Resolved
We've resolved all issues on app.dexi.io and things should be spinning happily once more. We apologise for the inconvenience - and do let us know if you have any questions or concerns.
Posted 7 months ago. Sep 28, 2017 - 06:10 CEST
Investigating
We're currently investigating issues on app.dexi.io - we're currently investigating and will write an update here as soon as possible.
Posted 7 months ago. Sep 28, 2017 - 06:10 CEST